
MINITAB for Windows Release 14 May 2004

Installing MINITAB
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Networks, Labs, and Stand-Alone PCs

Installing MINITAB
You can install the Annual Version of MINITAB: 

■ Locally on PCs that share an annual license agreement. The PCs can be connected to 
a network. 

■ On a file server that is networked to multiple client PCs, each client PC sharing the 
copy of MINITAB that is installed on the file server. (Network client files must be 
installed on each client PC. See Installing Network Client Files on page 4.)

To install MINITAB, follow the directions below. You can also install MINITAB using a 
silent installation. See Silent Installations on page 2.
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Note You cannot install the Annual Version of MINITAB without the 
information from the Site ID Specification letter. A Site ID Specification 
letter for this release of MINITAB was mailed to your site administrator 
(usually the person who purchased MINITAB). If you cannot locate this letter, 
contact your Minitab sales representative or local representative.



Silent Installations

2 Installing MINITAB, Annual Version

h To install MINITAB

Full installation takes between 2 and 3 minutes, depending on your system. You must 
have local adminstrative privileges to install MINITAB.

1 Exit all other applications, including all virus scanning software.

2 Place the CD-ROM disk into your CD-ROM drive. If Autorun is enabled on your 
system, the installation starts automatically and you can skip steps 3 and 4.

3 From the Windows Taskbar, choose Start ➤ Run. 

4 Type the CD-ROM drive letter followed by :\SETUP (for example, D:\SETUP); or click 
Browse, locate and select the MINITAB SETUP.EXE, then click Open. Click OK.

5 Follow the prompts on the screen. 

■ Enter the serial number printed on the CD envelope.

■ Enter your Site ID information.

■ Choose one of the following installation types:
– A complete installation, which installs the program, sample data sets, and all 

Help files
– A custom installation, which allows you to choose the files you want to install

6 If you installed to a network file server, install the network client files on each PC that 
will run MINITAB. See Installing Network Client Files on page 4.

Silent Installations
During a silent installation, MINITAB installs automatically without any displays or 
prompts. The program reads necessary information from a text file, called a response file, 

Note If you are installing MINITAB on a file server that is running a non-Windows 
operating system, see the operating system documentation for program 
installation instructions.

Type or browse to a location for the 
license information file.
For network installations, place the 
license information in a folder that 
is available to all the PCs. See Using 
UNC paths instead of drive letters for 
license information on page 6.

Type the Header from the Site ID 
Specification letter exactly as it 
appears (it is case-sensitive). The 
header is usually the name of your 
company or organization. 

Type the 15-digit Authorization 
Code from the Site ID Specification 
letter.
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in place of direct user feedback. Silent installations allow system administrators to quickly 
and uniformly install MINITAB on multiple PCs. 

Response file

A response file contains the necessary responses to each dialog box displayed during the 
installation. 

h To create a response file for silent installations

1 Exit all other applications, including all virus scanning software.

2 If MINITAB is already installed, choose Start ➤ Settings ➤ Control Panel ➤ Add/
Remove Programs and uninstall it. 

3 If you are running SETUP.EXE from the CD-ROM disk, place the disk into your 
CD-ROM drive. If Autorun starts the installation program, cancel out of the program.

4 From the Windows Taskbar, choose Start ➤ Run. 

5 Type the CD-ROM drive letter followed by :\SETUP (for example, D:\SETUP); or click 
Browse, locate and select the MINITAB SETUP.EXE, then click Open.

6 In Run, after SETUP.EXE, type a space followed by /r. For example, if the setup 
program is in the Minitab Install folder under Program Files, the entry would look 
like this: “C:\PROGRAM FILES\ MINITAB INSTALL\SETUP.EXE” /r. 

7 Click OK. The installation program begins.

8 Follow the prompts on the screen. After completing the installation, a response file is 
generated in the Windows or WINNT directory.

9 Copy or move the response file, SETUP.ISS, from the Windows or WINNT directory 
to one of the following:

■ The folder on your network that contains the MINITAB SETUP.EXE file

■ A different location, such as a floppy disk

h To execute a silent install

1 Exit all other applications, including all virus scanning software.

2 If MINITAB is already installed, choose Start ➤ Settings ➤ Control Panel ➤ Add/
Remove Programs and uninstall it. 

3 If you are running SETUP.EXE from the CD-ROM disk, place it into your CD-ROM 
drive. If Autorun starts the installation program, cancel out of the program.

4 From the Windows Taskbar, choose Start ➤ Run.

5 Type the CD-ROM drive letter followed by :\SETUP (for example, D:\SETUP); or click 
Browse, locate and select the MINITAB SETUP.EXE, then click Open.

6 Do one of the following:
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■ If the response file is on your network in the same folder as SETUP.EXE, in Run, 
after SETUP.EXE, type a space followed by /s.

■ If the response file is not located in the same folder as SETUP.EXE, in Run, after 
SETUP.EXE, type a space followed by /s /f1"(drive and path)\SETUP.ISS". (The 
“1” in “f1” is the number one, not the lower case letter L.) For example, if 
SETUP.EXE is on your MINITAB CD in the E drive and SETUP.ISS is on a floppy 
disk in the A drive, the entry would look like this: 
E:\SETUP.EXE /s /f1"A:\SETUP.ISS".

7 Click OK. The installation takes between 2 and 3 minutes.

Confirming installation

When the silent installation is complete, the log file SETUP.LOG is created in the folder 
that contains SETUP.ISS. The log file records whether an installation was successful, 
and logs any error codes; a set-up program running silently does not display any dialog 
boxes, even if an error occurs. 

The last line of the log contains a result code. If the result code is zero, the silent 
installation was successful. A negative result code indicates that the silent installation 
failed, and is generally caused by MINITAB being previously installed on either the 
machine that created the response file or one of the machines running the silent 
installation. For more information on error codes, go to 
http://www.minitab.com/support/answers/ and search for silent.

Installing Network Client Files

Follow this procedure only if you installed MINITAB on a network file server and you want 
to set up multiple PCs to share that single copy of MINITAB.

The network client installer creates a MINITAB program group or folder, MINITAB icons, 
and other files and folders that the PC needs. You can run the installation from the 
Admin folder of the CD-ROM disk. You can also copy the Admin folder to the network 
server and run the setup program for all networked PCs directly from there. 

h To install the network client files

1 Install MINITAB on the file server. See Installing MINITAB on page 1.

2 On the client PC, exit all other applications, including all virus scanning software.

3 If you are running the installation from the CD-ROM disk, insert it into the CD-ROM 
drive. If Autorun starts the installation program, cancel out of the program. 

Caution This procedure is only for network system administrators. 

Note You can also do a silent installation of client files. See Silent Installations on 
page 2.
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4 From the Windows Taskbar, choose Start ➤ Run.

5 Type the CD-ROM drive letter followed by :\ADMIN\SETUP (for example, 
D:\ADMIN\SETUP); or click Browse, locate and select SETUP.EXE in the Admin folder, 
then click Open. Click OK.

6 Follow the instructions on your screen.

Renewing Your License
Your annual license expires one year after purchasing or renewing the license, regardless 
of when you installed MINITAB. MINITAB does not start if the license is expired.

To renew your license, you need a new header and authorization code. Contact your site 
administrator, Minitab sales representative, or local representative to receive a new Site 
ID Specification letter.

You can enter your new header and authorization code in the installation program. You 
do not need to reinstall all MINITAB files -- the installation program simply provides an 
easy way to update the header and code.

h To reactivate MINITAB using Add/Delete Programs

1 Exit all other applications.

2 Choose Start ➤ Settings ➤ Control Panel ➤ Add/Remove Programs.

3 Select MINITAB Release 14 and click Change/Remove.

4 Under What action would you like to perform? choose Update annual license 
information. Click Next.

5 Type the new Site ID Header and Site ID Code. Click Next, then click Finish.

h To reactivate MINITAB using the CD-ROM disk

1 Exit all other applications.

2 Place the CD-ROM disk into your CD-ROM drive. If Autorun is enabled on your 
system, the installation program starts automatically. Skip steps 3 and 4.

3 From the Windows Taskbar, choose Start ➤ Run.

4 Type the CD-ROM drive letter following by :\SETUP (for example, D:\SETUP); or click 
Browse, locate and select the MINITAB SETUP.EXE, then click Open. Click OK.

Note Each client PC must meet the system requirements for running MINITAB − 
including the requirements for the amount of installed RAM.

Note If you are an advanced system administrator, it may be faster to manually edit 
the license information file. See Advanced Tips for System Administrators on page 
6.
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5 Under What action would you like to perform? choose Update annual license 
information. Click Next.

6 Type the new Site ID Header and Site ID Code. Click Next, then click Finish.

Advanced Tips for System Administrators
To use the following techniques, you must be familiar with editing, moving, and setting 
the attributes of files on a network.

Manually updating the license information file

The MTBAN.TXT file contains your MINITAB license information. You can use a text 
editor to correct the site ID header and authorization code or to update this information 
when renewing your annual license. 

h To manually edit the license information file

1 Find the file MTBAN.TXT, which is located in the license path you specified when 
you installed MINITAB.
If you do not remember the path, look in the MTBAN.INI file, which is in the main 
MINITAB folder. Search for the line that begins LicenseInfoPath=.

2 Change the file attributes of MTBAN.TXT so that it is not read-only. In Windows 
Explorer, select the file, choose File ➤ Properties, then uncheck Read-only. 

3 With an ASCII text editor like Notepad, open MTBAN.TXT. The file consists of three 
lines similar to these:

4 In the first line of the file, type the new header exactly as it is appears in the Site ID 
Specification letter (it is case-sensitive). The header may be the same as in your 
previous license.

5 In the third line of the file, type the new 15-digit authorization code as it appears in the 
Site ID Specification letter.

6 Save the file as a plain text file (MTBAN.TXT).

7 Change the file attributes of MTBAN.TXT back to read-only. In Windows Explorer, 
select the file, choose File ➤ Properties, and check Read-only.

Using UNC paths instead of drive letters for license information

Multiple PCs can share the same license information file (MTBAN.TXT) if the file is 
stored on a network. In this situation, you should edit the MTBAN.INI file to use a UNC 
(Universal Naming Convention) path, instead of drive letters, to specify the location of 
the license file.

ALFORD ELECTRONICS
000000000000000
014789387364015

Header

Line of 15 zeros

15-digit authorization code
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h To change a drive letter to a UNC path

1 In a text editor, open MTBAN.INI, located in the MINITAB folder. 

2 Locate the line beginning with LicenseInfoPath=. 

3 After the = sign, replace the existing path name with the UNC path. For example, to 
save the license file to a folder called MINITAB 14 in the SHARED folder of 
SERVER1, type LicenseInfoPath=\\SERVER1\SHARED\MINITAB 14.

4 Save the file.

Identical settings on multiple PCs

Profiles in MINITAB store any changes to MINITAB factory default settings made using 
Tools ➤ Options and Tools ➤ Customize, as well as custom date/time formats and value 
order settings. Each time you modify a setting, MINITAB stores the change in a user 
profile so that it is in effect for the next MINITAB session. All settings you change during a 
session are stored in the uppermost profile located under Active Profiles in Tools ➤ 
Manage Profiles.

To ensure that multiple PCs have identical settings, administrators can use Manage 
Profiles to create and export a preinstall profile as a registry file named ORGDEFS.REG. 
Store this file with the MINITAB setup files on the server from which MINITAB is to be 
installed. During network installation, MINITAB places the file in users’ \\MINITAB 
14\PROFILES folders. When a user opens MINITAB for the first time, the file is 
imported. The imported profile is named $$ORGANIZATIONALDEFAULTS and 
shows up as the second profile in Active Profiles.

h To create the preinstall profile

1 Install MINITAB on any PC or network server.

2 Open MINITAB. Adjust any settings you want to share on multiple PCs.

3 Choose Tools ➤ Manage Profiles.

4 Click  to move the profile MyProfile from Active profiles to Available profiles. 
(To be exported, profiles must be under Available Profiles.)

5 With the profile selected, click Export.

6 In Save In, browse to the network server folder that contains the MINITAB setup files.

7 In File name, rename MyProfile to orgdefs.reg. Click Save.

The new settings take effect in MINITAB without users having to make any modifications.

Note For more information on profiles, go to Profiles in the MINITAB Help index. 
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Troubleshooting Installation/Startup

If MINITAB does not start because of missing or invalid license

To run MINITAB, you must have a valid license information file. If the information file is 
not valid or MINITAB cannot find the information, MINITAB displays one of the following 
error messages:

■ License control file is missing − You need to replace the license path in the 
MTBAN.INI file, located in the MINITAB folder. Find the line beginning with 
LicenseInfoPath= and type the correct path. To use a UNC code, see Using UNC 
paths instead of drive letters for license information on page 6.

■ License control file invalid format − You need to replace either the authorization code 
or the case-sensitive header in the MTBAN.TXT file. You can either run the 
installation program again and type a new header and code, or edit the license 
information text file. See Renewing Your License on page 5 or Manually updating the 
license information file on page 6.

If networked PCs cannot find data or macros

All licensed PCs must have read/execute access to the folders (not files) that MINITAB 
installs. You also need read/execute access to the folder where the annual license file is 
stored.

Note To protect the original content, make all files in these folders read-only. In 
Windows Explorer, select the files, then choose File ➤ Properties and check 
Read-only.
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