Chapter 1  Layout

1.1 Introduction

What is Layout?
Layout is a two and a half dimensional graphical design tool intended for electronic integrated circuit and MEMS applications.

Installing Layout
Decompress the contents of the folder into the target directory of your choice.

How to create a new design
1. From the file menu choose File→New. This opens the New window. (See Figure 1.1)
2. Choose Design then click Ok. (See Figure 1.1)

Figure 1.1 Creates a new design

1.2 Basic Concepts

Layout was developed as a mask design tool. Layout uses layers to distinguish masks. Objects can only be placed on the “active” layer. Layout also allows you to have hierarchical objects to reuse components at any level of the design.

1.2.1 Basic Interface

Layout’s Graphical User Interface (GUI) is typical of windowed applications. The following are explanations of some features of the interface that might be out-of-the-ordinary.

1.2.1.1 Design Windows

Layout can open multiple designs and can control their arrangement using menu selections from the Window menu or using the toolbar buttons. Each design has a ±20,000,000 λ (lambda) coordinate space, where a λ is an arbitrary unit of length whose actual value will depend on the technology used for fabrication. At maximum zoom, each pixel on the display represents 1/100 of a λ. It is also possible to open multiple windows for a single design (File→New→View of current design). Each design window can show a portion of the design space. In Figure 1.2, there are three windows labeled “a”, “b” and “c”. Window “c” is the entire image of the design. This design has one wire object and two rectangular objects. Window “a” shows one of the rectangles and window “b” shows the other one.
Layout responds to double-clicking an instance of a composite object by opening a new window. The new window shows only the contents of the composite object. (More detailed information can be found in section 3.4.1.2).

Figure 1.2  Multiple design windows

1.2.1.2 Status Bar
To establish exact co-ordinates in the work space, you can observe the current mouse position on the left side of the status bar at the bottom of the main window. Clicking on the Units or Snap in the status bar will allow you to change them. Clicking on the Layer will revert to the previous layer. Hints to the operation of the tools are given on the right side of the status bar.

1.2.1.3 Grid:
The grid is shown as green dots in the design space. A window to edit grid properties can be opened by clicking “Snap” on the status bar. (See Figure 1.3) The grid will disappear if the on-screen density of the dots becomes too high. The Visible Grid Size sets the distance between each of the dots. The units pull-down controls the units of measurement, based of the size of $\lambda$. In Figure 1.3, each dot will be separated by $1 \lambda$, and the snap grid will be $\frac{1}{2} \lambda$ as we have 2 Snaps per Grid.
1.2.1.4 Units:

All design can be done in absolute units instead of $\lambda$ by setting the size of lambda and the display units in the dialog box shown in Figure 1.4. The units can be changed by clicking units on the status bar or Edit → Design Properties.

**Figure 1.4** Units properties window

1.2.1.5 Snap:

*Layout* has a snap mode. If it is enabled, the effective mouse position will be rounded to the nearest snap location. The snaps per grid can be set in the grid properties window. (See Figure 1.3) Snap mode can prevent the mouse from reaching an object handle that is located off-grid. To temporarily suspend Snap mode, hold down the Shift key.

1.2.1.6 Cut / Copy and Paste

When used on any a single object, cut / copy and paste behave as expected. If multiple objects are selected, the originally selected objects stay separated, while the copies that are pasted will be grouped objects. (Grouped objects are discussed in section 3.4) If desired, the original objects may be grouped before cut/copy.

1.2.2 Hierarchical Design and Reuse

*Layout* can create a new hierarchical object by grouping existing objects. *Layout* can group objects on the same layer into a “macro” or on multiple layers into a “composite.” Figure 1.5 is an example of the PLA Full Adder design. This design has composite objects named, “PLA_andPlane,” “PLA_pullup” and so on. These objects are reused in the design, which saves memory to allow larger designs. While the number of layers is not limited, the hierarchical levels may be limited by the graphics card to as few as 31 levels.¹ (More details about hierarchical level can be found in section 3.4.2)

¹ Based on the minimum matrix stack size of 32. See OpenGL®, p. 148
1.2.3 Accessibility

*Layout* supports the accessibility. *Layout* can be used without a mouse. By holding down left Shift key, left Alt key and NumLock key, “MouseKeys mode” will be activated. The MouseKeys allows you to simulate the mouse behavior with the keyboard. Consult the windows help menu for more detailed information about MouseKeys.

---

Figure 1.5  PLA Full Adder

---

2 Weste & Harris p.754
Chapter 2  Layers

2.1  What are Layers?

Each Composite object contains a stack of layers. These layers are drawn on the screen in a specific order, with higher numbered layers appearing closer to the viewer, potentially obscuring lower numbered layers. This viewing order can be modified in the layer creation/editing dialog box. Layout can have unlimited number of layers. Layout helps you to switch between layers and places objects only on the “active layer”. The “active layer” can be chosen from Layers→Active, or from the visible layers sidebar by clicking on the layer name (not the checkbox). The viewing order can be temporarily modified to bring the active layer closest to the viewer using the Layers→Active on top menu selection.

2.1.1  Creating a new layer

When Layout creates a new design space (See Section 1.1), one layer called default layer is automatically created. If you want to have more layers, a new layer can be added by choosing Layers → Add new from Layers menu. (See Figure 2.1  Add a new layer)

This opens the Layer Edit window. (See Figure 2.2  Layer attribute) Set the properties in the Layer Edit window then click OK. The color and the fill pattern of this layer can be changed by clicking the square images next and under the label.
2.2 Layer Properties

Each layer has properties associated with it. These properties can be changed from the Layers menu. (Layers → properties of active) Details of each label can be found in the Table 2-1.

<table>
<thead>
<tr>
<th>Label</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Layer Name</td>
<td>The layer name has to be unique and limited within four capitalized Alphabets to be cif compatible.</td>
</tr>
<tr>
<td>Color</td>
<td>Click the square color sample window to change the color</td>
</tr>
<tr>
<td>Order</td>
<td>The layer with small order is placed bottom of the higher layer order</td>
</tr>
<tr>
<td>Border</td>
<td>Shows border of the objects on this layer</td>
</tr>
<tr>
<td>Fill</td>
<td>Sets if an object on this layer will be filled with the color associated to the layer or not.</td>
</tr>
<tr>
<td>Fill Pattern</td>
<td>Sets the transparency. If the fill property is disabled, Fill Pattern window will not be shown. (See Figure 2.3 Available Fill Pattern)</td>
</tr>
<tr>
<td>Mirror</td>
<td>Forces to all text objects to be mirrored. This is useful for circuit board design and some MEMS operations.</td>
</tr>
<tr>
<td>Negative</td>
<td>Generates a negative mask</td>
</tr>
<tr>
<td>Rounded Wire</td>
<td>Forces all wires on this layer to have rounded ends and joints. (See section 3.1.4.2)</td>
</tr>
<tr>
<td>Visible</td>
<td>Set visibility of the objects on this layer</td>
</tr>
</tbody>
</table>
The layer property also has default units and buddy layer. The default units set the following initial values: Radius, Wire Width, **Text Height**, and Radial accuracy. All properties except the radial accuracy can be set separately to each object from its object properties. The buddy layer has not been implemented yet.

In the fill pattern window, x and y phase can be set. These phase number will shift fill pattern so that the same pattern can be used many times. (See Figure 2.4)

![Available Fill Pattern](image)

**Figure 2.3** Available Fill Pattern

![Phase shift](image)

**Figure 2.4** Same Fill Pattern with different x phase value

### 2.3 Active layer

All objects can be only placed on the “active layer”. The “active layer” can be force to be the top of the layer stack by using active on top option under the Layers menu. The “active layer” can be set from layer menu. (Layers → Active → choose the “active layer”) The check mark will be shown next to the “active layer”. (See Figure 2.5)
2.4 **Layer Menu**

The sub menu of layer menu and their explanation can be found in the Table 2-2.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Previous F10</td>
<td>Change active layer to the previous active layer</td>
</tr>
<tr>
<td>Sort List</td>
<td>Sorts the layer list alphabetically</td>
</tr>
<tr>
<td>Layer names</td>
<td>Choose one to make it active</td>
</tr>
<tr>
<td>Active on top</td>
<td>Opens the Layer Edit Window of the active layer</td>
</tr>
<tr>
<td>Selection only on active</td>
<td>Forces the active layers to be on top of the layer stack</td>
</tr>
<tr>
<td>Visible</td>
<td>Limits the selection of the objects to active layer</td>
</tr>
<tr>
<td>Show all</td>
<td>Shows all objects in the design</td>
</tr>
<tr>
<td>Hide all but active</td>
<td>Hides all objects on the non-active layer</td>
</tr>
<tr>
<td>Choose visible layers</td>
<td>Selects visible layers</td>
</tr>
<tr>
<td>Move selected to</td>
<td>Moves the selected objects on the one layer (source layer) to the other layer (destination layer).</td>
</tr>
<tr>
<td>-----------------</td>
<td>----------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Add new</td>
<td>Adds new layer into the design</td>
</tr>
</tbody>
</table>

**Caution:** Selection only on active has to be disabled to select composite objects.
Chapter 3 Tools

3.1 Drawing tools

Layout has nine drawing tools. These nine tools can be classified into five categories: Circular objects, Rectangular objects, Wire objects, Polygon object and Text object. (See Table 3-1)

<table>
<thead>
<tr>
<th>Tool</th>
<th>Button</th>
<th>Requires</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arc</td>
<td></td>
<td>Center, two radii, start and sweep angles</td>
</tr>
<tr>
<td>Circle</td>
<td></td>
<td>Center and radius</td>
</tr>
<tr>
<td>Ring</td>
<td></td>
<td>Center and two radii</td>
</tr>
<tr>
<td>Rectangle</td>
<td></td>
<td>Center and one corner</td>
</tr>
<tr>
<td>Rounded Rectangle</td>
<td></td>
<td>Center and one corner</td>
</tr>
<tr>
<td>Polygon</td>
<td></td>
<td>At least three points terminated with a double-click</td>
</tr>
<tr>
<td>Wire 45</td>
<td></td>
<td>At least two points terminated with a double-click</td>
</tr>
<tr>
<td>Free Wire</td>
<td></td>
<td>At least two points terminated with a double-click</td>
</tr>
<tr>
<td>Text</td>
<td></td>
<td>Base position, at least one character and an Enter</td>
</tr>
</tbody>
</table>

3.1.1.1 Keyboard Entry

Input x and y coordinates with a comma separating the x and y coordinates. Press enter to mark each set of coordinates. Radii and angles do not require a comma, only enter.

(Currently, Keyboard drawing is limited to the rectangle, the rounded rectangle, the ring tool, and Example: Drawing a rectangle with Keyboard Entry

1. From Tools menu, choose Rectangle.
2. Enter x and y value for the center of the rectangle. Then hit the Enter Key.
3. Enter x and y value for one of the corner of the rectangle. Then hit Enter Key.

3.1.1.2 Mouse Entry

Indicate desired position by left clicking the mouse in the design space. Mouse position will be snapped to the nearest grid point by default. To change snap behavior, click on snap on the status bar.

3.1.2 Drawing circular objects (Circle, Ring and Arc)

The circular drawing tool shares its basic steps. The drawing tool adds more steps for the Ring and the arc tool.

3.1.2.1 Radial Accuracy

Each circular object is approximated with a regular polygon inscribed within the circle. The number of sides used to generate the polygon is controlled by the default radial accuracy. The error in the Error! Reference source not found. will be less than or equal to the radial accuracy. The smaller radial accuracy draws more accurate circular objects, but it has to be bigger than or equal to 0.01 (See Figure 3.2)
3.1.2.2 Circle objects

1. Select the Circle tool.
2. Specify the center of a circle by left click.
3. Move the mouse until the circle drawn with the rubber band grows the size it needs to be. Then left click.

3.1.2.3 Ring objects

1. Select the Ring tool.
2. Specify the center of a ring by left click.
3. Move the mouse until the circle drawn with the rubber band grows the size it needs to be. Then left click.
4. Move the mouse until the second circle drawn with the rubber band grows the size it needs to be. Then left click.

3.1.2.4 Arc objects.

1. Select the Arc tool.
2. Specify the center of an arc by left click.
3. Move the mouse until the circle drawn with the rubber band grows the size it needs to be. Then left click.

Caution: *Layout* will automatically decrease the number of sides during output file generation, if the object cannot be fabricated with the specified radial accuracy.
4. Move the cursor along the ring drawn as rubber band until the line points where the arc needs to be started. Then left click.

5. Move the cursor along with the ring until the line points where the arc ends. Then **double-click**. (See Figure 3.3)

![Figure 3.3 How to draw an arc](image)

### 3.1.3 Rectangular Objects (Rounded Rectangle and Rectangle)

A Rectangular object is drawn from the center to its corner.

#### 3.1.3.1 Rectangle Objects

1. Select the Rectangle tool.
2. Specify the center of a rectangle by left click.
3. Move the mouse until the rectangle drawn with rubber band grows the size it needs to be. Then left click.

#### 3.1.3.2 Rounded Rectangle Objects

1. Select the Rounded Rectangle tool.
2. Specify the center of a rounded rectangle by left click.
3. Move the mouse until the rounded rectangle drawn with the rubber band grows the size it needs to be.
4. Then left click. (See Figure 3.4)

![Figure 3.4 Drawing a Rounded Rectangle object](image)

### 3.1.4 Wire Objects (Wire 45 and Free Wire)

*Layout* has two different wire tools called the Wire 45 and the Free Wire. The default wire width of both types of wire is set in the Layer Edit window. To change the wire width of a particular wire, change the width from the object properties. (Select the wire, then **Edit → Object Properties**, or Right click, **Object Properties**.) Object properties are associated with each object, therefore changes made in this dialog will not affect other objects. The difference between the Wire 45 tool and the Free Wire tool is only in the possible orientations of the wire segments. The Wire 45 tool only allows multiples of 45 degrees while the Free Wire tool allows any angle. (See Figure 3.6)
3.1.4.1 Drawing Wires

1. Select the Wire 45 or the Free Wire tool.
2. Specify the starting point of a wire by clicking at the desired location.
3. Move the cursor to the wire segment’s endpoint, then click.
4. Specify additional points for the remaining segments of the wire by clicking, until reaching the final segment’s endpoint, then **double-click**.

(See Figure 3.5)

![Figure 3.5](image)

**Figure 3.5** Drawing a wire object

![Figure 3.6](image)

**Figure 3.6** A Wire 45 object (a) and a Free Wire object (b)

Notice the differences in handle positions.

3.1.4.2 Drawing Rounded Wires

1. Make the layer for the wires to be drawn on active by selecting **Layers→Active→<layer name>**
2. Open the Layer Properties window by selecting **Layers→Properties of Active...**
3. Check the box next to the Rounded Wires. Then click ok. (See Figure 3.7)

Caution: The circles placed at the endpoints of the wire segments will be approximated on-screen (and in some mask making equipment) by a polygon. The number of sides used in that polygon is controlled by radial accuracy. (See Section 3.1.2.1)

![Figure 3.7](image)

**Figure 3.7** (a) Regular Wire (b) Rounded wire with radial accuracy 0.05

3.1.5 Text Objects

The text tool places characters within the design space. The **default height of a text object is set in the Layer Edit window.** You can change the text height from the object properties (See section 2.2).
3.1.5.1 Drawing Text Objects

1. Select the Text tool.
2. Specify the base position of the characters by left click. This position is normally to the left of the first character at the baseline. Any descender characters (g, j, p, q, y) will descend below the baseline.
3. Type the characters. The characters can be edited before hitting the Enter key or left click.
4. Hit the Enter key to finish typing the characters. (See Figure 3.8) Or, click to start a new text object.

![Figure 3.8 Drawing a text object](image)

3.1.6 Polygon Objects

Layout allows the design of complicated polygons and automates the process of converting these to the simple polygons required for mask making.

3.1.6.1 Drawing polygon objects

1. Select the Polygon Tool.
2. Specify the position in the design space for the first vertex of a polygon. Continue selecting the next vertex as it requires. Then double-click. (See Figure 3.9)
3.2 **Modifying un-grouped objects**

*Layout* can modify only selected objects in the design. A non-grouped object can be modified by changing its object properties. This can be done by either from mouse entry or keyboard entry.

3.2.1 **Selection Modes**

*Layout* has two selection modes. Selection modes can be changed from *Layers* menu. The selection modes and the visibility of layers are strongly related. *Layout* cannot select invisible objects. (See Figure 3.10)

3.2.1.1 **Selects all visible objects mode**

If selects only on active is not enabled, the *Layout* is always in this selection mode. In this mode, all visible objects in the design can be selected. Therefore, all the visible objects on the point where you clicked will be selected. This mode also allows you to select a composite object.

3.2.1.2 **Selects only on active mode**

This mode limits the selection only to the active layer. However, the composite object cannot be selected with this mode.

3.2.2 **Handles of the Objects**

Each object has the handles associated with it. The handles are shown on the boundary and the center of the selected objects. (See Figure 3.11a) The handles can be used to modify the objects properties such as size, location and so on.

Handles are drawn using binary exclusive or. This may cause invisible handles. If a handle of two objects shares their location, handle of both objects becomes invisible. If the invisible handle needs to be selected, move the cursor to the point where the invisible handles should exist. The cursor should become the move cursor if the cursor is on top of the invisible handles. (See Figure 3.11b)
3.2.3 Changing the object properties with Mouse Entry

Most object properties can be modified by the mouse entry. There are some properties that can be only modified from the object properties window.

3.2.3.1 How to modify an object with mouse Entry

1. Select an object to be modified. If an object is selected, it will show some handles along the boundary and the center of the object. The handles on the boundary of the object allows you to change its shape while the handle in the center of the object allows you to move the object. (The text object does not have a handle in the center. The handle appears on where the user clicked to set the base position can be used to move the objects. Others can rescale the object)

2. Move the precision cursor on top of the handles. If the handle is correctly selected, the cursor changes to the move cursor. The selection of a handle might be easily done by temporarily disabling the snap by pushing down the Shift key. Release the Shift key to enable the snap again, once the selection has been made.

3. Drag the mouse. Then release the button. (See Figure 3.12)

Some object properties cannot be changed with the previous method. Those properties can be only changed from the object properties.

1. Select an object and open the pop-up menu.
2. Choose object properties from pop-up menu.
3. Change the values in the Object Properties. Then click OK.

3.2.4 Changing the object properties with Keyboard Entry

All object properties can be modified by changing object properties directly from the keyboard.

1. Select all objects. Be careful about the selection modes and visible layers. Objects can only be selected if they are visible.
2. Choose the **object properties** from **Edit** menu.
3. Switch between objects using the arrow buttons at the bottom of the object properties window. (See **Figure 3.13**)

![Figure 3.13](image)

**3.2.5 Rotating Objects**

Some objects are rotatable and can be rotated by following steps. (See **Figure 3.14**)

1. Select an object.
2. Select one of the handles on the boundary of the object.
3. Hold down the Alt key while dragging the mouse.

![Figure 3.14](image)

**3.2.6 Adding Wire segments to a Wire 45 object**

*Layout* can add a wire segment to either the end or the beginning of a Wire 45.

1. Select a Wire 45 object that a wire segment to be added to the beginning or the end.
2. Move the precision cursor onto the first or the last handle of the selected Wire 45.
3. Once the cursor changes into the move cursor, hold the Ctrl key down while dragging the mouse to add a new segment to the Wire 45. Then release the mouse bottom. (See **Figure 3.15**)

![Figure 3.15](image)
3.2.7 Adding wire segments to a Free Wire object

Usually we think of a wire as having two end points, however in Layout a new segment can be added to the start, the middle or the end of a Free Wire. There are two possible directions to add a new segment: Before or after the selected handle. Before and after are defined relative to the way the wire was drawn. The wires in the Figure 3.16 and Figure 3.17 were drawn from left to right.

1. Select a Free Wire object that a wire segment to be added to.
2. Move the precision cursor onto a handle of the selected Free Wire.
3. Once the cursor changes to the move cursor, hold the Ctrl key down while dragging the mouse to add a new segment.
4. Hold down Ctrl and Shift to add a segment before the handle. Then drag the mouse. (See Figure 3.16) Holding only the Ctrl key adds a segment to after the handle (see Figure 3.17)
5. Once the rubber band is started, release the key(s), unless the new point is intended to be off grid, in which case hold down the Shift key. Then release the left button of the mouse.

Figure 3.16 Add a new segment with the Ctrl key + the Shift key
3.2.8 Drawing Bypasses (only available for Wire 45)

Wire 45 tool can draw a bypass to get around some objects. (See Figure 3.19)

1. Select a wire that needs to have a bypass.
2. Move the cursor onto the handle which needs to be moved.
3. Hold down the Ctrl key while dragging the mouse. (See Figure 3.18)
4. Release the mouse button

3.2.9 Panning mode and zoom mode

Since the design space is very large, you might need to pan or zoom the screen.
3.2.9.1 How to pan

Alternative methods for panning:
1. Hold down the scroll wheel while dragging the mouse.
2. For vertical panning, roll the scroll wheel. For horizontal panning: roll the scroll wheel while holding down the shift key.
3. When no scroll wheel is available, right click to select the pan mode from the pop-up menu or select the pan tool from the tool bar. In pan mode, hold down the left mouse button while dragging, or use the arrow keys.

3.2.9.2 Zooming mode

*Layout* can zoom the objects in the design window. Also, *Layout* can set the zoom speed from *View menu → Change Zoom Speed*.

How to zoom

Alternative methods for zooming:
1. Roll scroll wheel while holding it down.
2. When no scroll wheel is available, right click to select the zoom mode from the pop-up menu, or select the zoom tool on the tool bar. Once in zoom mode, click to zoom in or ctrl-click to zoom out. Or hold down the left mouse button and drag to select the area to be displayed.
3. Hit F5 key to zoom out. F6 Key to zoom in.

3.2.3 Zoom Extent

This tool centers the image by adjusting the zoom and panning to show the entire composite in the window.

3.2.4 Move to the origin

Moves the coordinate system origin to the center of the screen and positions the cursor at the origin. This does not affect the zoom.

3.3 Grouping Objects

Grouping of the objects can form two different types of objects from the existing visible objects. (Visibility can be set from Layer Edit window or *Layers → Visible*.) When the objects on the multiple layers are grouped, *Layout* adds four handles at the corners of the grouped object and an optional fifth handle depending on how the grouped object was formed. The fifth handle can be explicitly created on the any place of a grouped object to align the grouped objects. The fifth handle will be located at the origin, if it is located inside of the object. Otherwise, the point closest to the origin on the boundary of the grouped object becomes the fifth handle. If that closest point is one of the corners, then there will be only four handles. *Figure 3.20* has a fifth handle right near the upper right corner to aid in aligning itself with other objects. The grouped object’s name is defaulted to the integer number. This can be modified from the object properties menu.
3.3.1 Forming grouped objects

*Layout* has two methods to form a grouped object. Either group tool under the **Tools** menu or cut/copy and paste can create a grouped object. The grouped object cannot be scaled. All five handles can be used to move the grouped object. Following three methods will form grouped object in the memory and then place the instances of grouped objects into design.

3.3.1.1 Method 1: Using Group tool

1. Selects all objects that form a new grouped object.
2. From the **Tools** menu, choose **Tools→Group**. (See Figure 3.21)

3.3.1.2 Method 2: Cut/copy and Paste

The cut/copy and paste may form a grouped object if multiple objects are selected. The originally selected objects stay as separate objects.

![Figure 3.21](image) Forming a grouped object (left) and grouped object (right)

3.3.2 Ungrouping objects

*Layout* can ungroup a selected grouped object by using ungroup tool under **Tools** menu. (See Figure 3.22)

1. Select exactly one instance that needs to be ungrouped. You cannot select any other objects.
2. From the **Tools** menu, choose **Tools→Ungroup**.

---

3 Weste & Harris p.754
3.4 More about grouped objects

*Layout* creates two different types of grouped object depending on how the grouped object is formed. The grouped object formed only from the single layer objects are called a macro object while the grouped objects formed from multiple layers are called a composite object.

3.4.1 Macro Objects

The macro object is formed from the objects on a single layer. The macro object does not retain layer information. A macro object is used to keep the shape of the original objects. For example, if you need the same shape of objects on a different layer, you can create a macro object and place them on different layers. When a macro object is created, the *Layout* assigns the negative integer as its default name.

3.4.2 Composite Objects

A composite object is formed from the objects on the multiple layers or the grouping with the composite objects. A composite object retains the layer information and may have a fifth handle. A composite object is created from the objects placed on the different layers. While a macro object can be placed on any layer, a composite object always placed on the same layers as the original objects. A composite object **CANNOT BE SELECTED** if selection only on active is enabled. Both macro object and composite object is just the structure in the memory. All macro or composite objects in the design are the instances of the macro or composite objects. When a composite object is created, *Layout* assigns positive integer as its default name.

3.4.2 Hierarchical view level

To show contents of a composite object (shown as boundary box), the hierarchical level need to be changed. From the view menu, choose **View→Change Hierarchy level**. This opens a new window named Composite hierarchy edit. This value is defaulted to 1 that shows a composite object as a boundary. In the Figure 3.23, Hierarchical level 1, 2, 3 of the same design is demonstrated. Hierarchical view level is completely window independent. IE changing hierarchical view level of a window does not change the hierarchical view level of other windows.
3.4.3 How to modify a composite object

There are three different ways of modifying a composite object. All three methods require choosing only one instance of the composite. In order to conserve memory, Layout will share common composite objects between all opened designs. The first two methods shown below will cause any modification to appear in all open designs that share the composite. If you do not want the changes appear to other designs, you should close the windows before you make modification.

3.4.3.1 Method 1: Push into composite

Push into composite allows user to display contents of the selected composite in the current window. This method modifies the composite object in the memory. Therefore, all the instances of the composite object will be changed.

1. Select an instance of the desired composite object.
2. From the window menu, choose Window→Push into composite or (F3).
3. Make modification.
4. From the window menu, choose Window→Pop out of composite or (F4).

3.4.3.2 Method 2: Double-clicking

Layout can display contents of a selected composite object in a new window by double-clicking exactly one selected composite object. Any modification made in the newly opened window will be reflected to all instances of the composite object.

3.4.3.3 Method 3: Ungroup, modify, Group

Warning: Use of this method is highly discouraged. This method uses more memory space and does not reflect changes to other instances.

1. Select and ungroup a composite object that needs to be modified.
2. Make modification to the design then group them to form a new composite object.

Unlike method 1, this method does not reflect the modifications to all instances in the design. The modification is only to the newly formed grouped object. This is caused because method 2 does not modify a grouped object in the memory.

3.4.4 Array

The array tool creates either a circular or a rectangular array of composite object.

How to create array

From the Tools menu, choose Tools→Array→<type of array>
This will open an Array properties box.

Rectangular array

Specify size of row, column, x pitch, and y pitch.

Circular array

Specify radial to the center of object, start angle, step angle in degree.
Chapter 4    Designing with multiple windows

Layout can open multiple windows for any design space. Those multiple windows can show different portions of the same design. (See Figure 4.2) “Figure 4.2 c” is the entire design. It has a wire connecting two rectangular objects. This is done by opening two more windows that displays left box and right box. (See section 4.1) Since both new windows are associated with the same design, you can specify the beginning and the ending of a wire object in these new windows. The windows can be distinguished by its name.

4.1 Opening a new design window

1. From the file menu, choose File→New. This opens the New window
2. Click the radio button next to “View of current design”. Then click ok. (See Figure 4.1)
Figure 4.2  Multiple windows
References
